You are not logged in.

Dear visitor, welcome to Skin Consortium. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, July 21st 2008, 3:31pm

Color themes or lack of

Hi

Let me introduce myself as I am a newbie. My user name is 'alkey'.

I have downloaded and installed Winamp v 5.54 Pro on top of Winamp v 5.13 Pro.

Previous to doing this I had installed CPRO Insomnis v2 skin also ClassicPRO v 1.03 was installed. I did get warnings via the black and red warning box that problems could arise because I was only using Winamp v5.13 but I went ahead all the same and strangely everything went OK. The skin worked also I was able to use the 'color themes'. I then decided to install Winamp v 5.54 everything went really well, I must admit things worked better with the latest verson of Winamp, BUT, now I can't get any 'color themes' to install I re-downloaded and re-installed 'Insomnis' and ClassicPRO 1.03 but still no 'color themes' available in the drop down menus or any sign of them in my Winamp folder.

I do not like deleting files willy-nilly, but I did see a 'trick' in another thread, for a different problem, where you could delete the %appdata%\winamp\studio.xnf file, now logically, this looks as if it would be the sensible thing to do in my case and then delete the 'Insomnis' skin and the 'ClassicPro v 1.03' plugin and re-install them. What do you think?

Best regards

alkey

martin.deimos

Ex-Nullsoftie

Posts: 5,840

Name: Martin

Location: Munich, Bavaria

Occupation: Student

  • Send private message

2

Monday, July 21st 2008, 3:43pm

basically deleting studio.xnf isn't bad - it just deletes skin specific settings like position etc.

as for the bug itself:
do you see any colorthemes if you go to winamp preferences (ctrl+p) - skins - modern skins and open the colorthemes tab?
Consultant for Software and Systems Engineering @ CQSE | mpdeimos @ twitter | mpdeimos.com
Past Projects: Winamp for Android | Songpier - Every Song becomes an App | Winamp

3

Monday, July 21st 2008, 5:04pm

color themes

Hi

No, I don't see any 'themes' at all,the tab is grayed out with the message "No Color Themes". I've been looking at firewalls etc to see if its my security software blocking anything. I doubt if it is security as it Informs me of any abnormalities and gives me the option to block or allow.

Thanks for your time and effort

alkey

4

Monday, July 21st 2008, 6:32pm

Hi alkey,

It could be that you are behind a nasty proxy that sends old cached files.
Are you 100% sure that you have the latest version of cPro-Insomnis v2?

osmosis

Professional

Posts: 38

Location: Cananada

  • Send private message

5

Monday, July 21st 2008, 6:46pm

I've got the version of Insomnis v2 that pieter posted on the WA forums. I don't see the colorthemes in Preferences | Modern Skins | Color Themes or in the right-click menu Options | Color Themes. They only show under the Color Themes display of the bottom drawer.

SLoB

SLoB

Posts: 4,064

Location: UK

Occupation: Designer and Software Engineer

  • Send private message

6

Monday, July 21st 2008, 7:25pm

Hi alkey, welcome to the SC forum :)


hmm, I get cts on the skin menu and with using one of the 5.54 pre-release beta versions still.

alkey you don't say which OS your using, assuming XP for the now? otherwise possibly even more issues on Vista

it is also possible you may have skins cached in temp folder.

you have nothing to lose really by deleting studio.xnf file, it gets rebuilt.

please let us know if that fixes it, if not then we can try a couple of other things.

pjn123

"Your future depends on your dreams. So go to sleep"

Posts: 2,969

Name: Pieter

Location: /\/¯¯¯¯¯\/\, South-Africa

Occupation: Auditor

  • Send private message

7

Monday, July 21st 2008, 9:36pm

@ alkey: Always good to start clean if your doing such a big jump in Winamp versions. Here is what I'll do:
- Backup your skins
- Backup your bookmarks
- Uninstall winamp
- Delete the "C:\Program Files\Winamp" folder
- Delete the "%appdata%/winamp" folder if you have it (wa5.13 didn't use those folder yet)
- Now install winamp, classicpro and any plugins you might have.

Then make sure you have Insomnis v2

@osmosis: Dont know how that is possible... maybe just another winamp bug. Maybe clean studio.xnf? I know of certain plugins that screw with Winamp menu's (like albumlist.. it will create a new themes menu on each refresh and dont delete the old skin one)

Think one of the main reasons that people have so much trouble with winamp is because their installer is so useless. I'll email someone to complain and give my suggestion:
- Uninstall must ask to delete "%appdata%/winamp" (atm it just leave it alone... and no one except the pro's know about this folder)
- Installer should be simplified. You have a screen that ask what stuff do you want to do in Winamp (like write cd, rip cd's, play use internet services, ...) .. but there can still be a custom setup that goes to the classic installer(like it is now). They are putting so much effort into extra stuff like now playing shit that they forget that people will only use Winamp if it works and dont cause to much trouble. Just watching a few youtube video reviews and reading a few forum/blog reviews from random people shows that one someone have some trouble with winamp crashing they just dont use it again. I'm 99%sure his/her trouble could have been fixed by just deleteing the "%appdata%/winamp" folder.
"I either want less corruption, or more chance to participate in it"

8

Tuesday, July 22nd 2008, 11:58pm

Thanks for the advice

Hi to everyone who responded to my problem.

Yes I do run XP Pro also my Winamp, CSPRO and Insomnis are all up to date, as I said my problem only started when I updated Winamp.

I haven't done much about the problem as I have been having a few problems that have kept me busy. ;(

I am now going to print off the advice given and work through them to see what clears up the problem. :)

I think I'll leave the uninstall procedure as the last resort. ;)

I should be back tonight (Wednesday) to let you all know what has transpired. As its 1:45 am here I'm going to print out the advice and then go to bed :sleeping: , its so hot and sticky here it tires you out.

Many thanks for your invaluable help.

Alkey :D

9

Wednesday, July 23rd 2008, 12:33am

Solved my problem, i think anyway.

I've got the version of Insomnis v2 that pieter posted on the WA forums. I don't see the colorthemes in Preferences | Modern Skins | Color Themes or in the right-click menu Options | Color Themes. They only show under the Color Themes display of the bottom drawer.
Hi Everyone :thumbsup:

I printed out the advice given and you know how it is, should go to bed, but, you just have to try something before you do. Well I tried the most straight forward advice given by Osmosis, see quote above, and yes there in the bottom drawer drop down menu is the color themes highlighted, clicked on it and all the color themes appeared in the bottom drawer and it was so easy to select and set the color I wanted. :thumbsup:
so once again thanks to everyone who contributed to helping me out, I'm going to keep the print outs 'cos you never know. :rolleyes:

Goodnight to you all

Alkey :sleeping:

SLoB

SLoB

Posts: 4,064

Location: UK

Occupation: Designer and Software Engineer

  • Send private message

10

Wednesday, July 23rd 2008, 10:47am

cool :) can't have you not using the colour themes heheh

do the themes show on the preferences too?

osmosis

Professional

Posts: 38

Location: Cananada

  • Send private message

11

Wednesday, July 23rd 2008, 6:08pm

Haha well alkey, I wasn't actually offering advice, just further reporting what I assumed was the same problem as I wa sexperiencing it. Either way, pieter was right, it's a studio.xnf problem and removing it (and losing all of my long-tweaked window sizes and skin settings) will resolve it.

SLoB

SLoB

Posts: 4,064

Location: UK

Occupation: Designer and Software Engineer

  • Send private message

12

Wednesday, July 23rd 2008, 6:18pm

you can edit studio.xnf manually, its only an xml file, providing you keep the structure right then you can remove entries

osmosis

Professional

Posts: 38

Location: Cananada

  • Send private message

13

Wednesday, July 23rd 2008, 6:26pm

Yeah, I just hacked a bunch of garbage from old skins I don't use anymore out of there and now it works! Awesome.

Edit: Though I think I've found a bug. Even with a fresh studio.xnf, there're problems with the Color Themes menus and other cPro related right-click Options submenu items not disappearing when you switch to another skin (I opened Winamp with insomnis and then switched to Winamp classic base skin). Appears to happen the other way too (ie. starting winamp in a classic skin then moving to cPro; no menu item changes until a winamp restart). This was probably the problem all along, as I was checking the colorthemes submenu by going to Insomnis from another cPro skin.

This post has been edited 2 times, last edit by "osmosis" (Jul 23rd 2008, 6:39pm)


pjn123

"Your future depends on your dreams. So go to sleep"

Posts: 2,969

Name: Pieter

Location: /\/¯¯¯¯¯\/\, South-Africa

Occupation: Auditor

  • Send private message

14

Wednesday, July 23rd 2008, 8:42pm

osmosis do you have any 3rd party plugins installed? (Winamp goes a little mad here with stuff like AlbumList2... there might be more...?)
"I either want less corruption, or more chance to participate in it"

15

Wednesday, July 23rd 2008, 9:27pm

Update on no color themes

Hi Everyone

I followed Osmosis's advice and used the bottom drawer method for obtaining the color themes, this method I like 'cos you have the scroll buttons and the set color button. I may be wrong but maybe this is the way the 'Designer' intended it to be.

I have also deleted the studio.xnf file just to tidy things up a bit. The only thing that happened was when I loaded Winamp after, it was fragmented, I suppose this was the .xnf file resetting itself. I managed in the end to change Winamps skins a couple of times and now, up to yet, I'm having no problems. Except for the fact that I still cannot access color themes via any drop down menus other than using the bottom drawer method. Logicaly if the 'Designer" intended that anyway, thats how it is. Also how many times are we actually going to change the skins, it isn't as though we will be changing them on the hour for eg. I currrently am using 'darkazura' and I will probably only change it to 'nights red' when I'm in the mood to sit in the dark listening to my music (now you know that I'm weird :D ), so a few seconds now and again to change the 'color theme' via the drawer method, for me, will not be a problem.

On a final note is "Nosmosis" the only skin that you can change the 'color themes' in? I have looked for more but it doesn't seem clear. I have tried some skins but theres no 'color themes' on any menus and also there isn't any showing on the bottom drawer so I am presuming that "Nosmosis" is the only 'colorizing' skin at present. If so, more please. ;)

Thanks for all the help given you have been a very fast responsive and helpful group of members, keep up the good work. :thumbsup:

Alkey :)

pjn123

"Your future depends on your dreams. So go to sleep"

Posts: 2,969

Name: Pieter

Location: /\/¯¯¯¯¯\/\, South-Africa

Occupation: Auditor

  • Send private message

16

Wednesday, July 23rd 2008, 9:52pm

Theres one more (atm)...

cPro Erbium... Its a very good example of what can be done ;)

cPro Erbium
"I either want less corruption, or more chance to participate in it"

osmosis

Professional

Posts: 38

Location: Cananada

  • Send private message

17

Thursday, July 24th 2008, 4:33am

osmosis do you have any 3rd party plugins installed? (Winamp goes a little mad here with stuff like AlbumList2... there might be more...?)
Your right, it is a 3rd party plugin.. I took them all out and adding them back, found the culprit was (i might have guessed..) Dynamic Library v2.0. I guess Joonas needs to use a slightly cleaner way to alter the menus.. :(

18

Thursday, July 24th 2008, 5:50pm

Latest on color themes no show

Hi Everyone

Now we have 2 skins to be able to judge the above problem with. Just downloaded and skinned Winamp with CPRO Erbium by Veroka, very nice too looks good in 'blueberry' and is very nice as a 'windowshade'.

Even on this skin you , well I can't, select 'color themes' by drop down menus only by the 'bottom drawer' method. Is this the same with anyone else whose downloaded 'Erbium'. If it is then its in the design and meant to be, if anyone else can select 'color themes' by drop down menus, then I do have a problem. :S

Thanks to all

Alkey

pjn123

"Your future depends on your dreams. So go to sleep"

Posts: 2,969

Name: Pieter

Location: /\/¯¯¯¯¯\/\, South-Africa

Occupation: Auditor

  • Send private message

19

Thursday, July 24th 2008, 6:06pm

If the skin have colorthemes its suppose to be here:
- Select Drawer Button >> Color Themes
- Right-Click main menu >> Options >> Color Themes
- Winamp prefs >> Skins >> Modern Skins >> Color Themes

All of the above works here
"I either want less corruption, or more chance to participate in it"

osmosis

Professional

Posts: 38

Location: Cananada

  • Send private message

20

Thursday, July 24th 2008, 7:38pm

alkey if you read my posts more closely I think you'll find the solutions.. try closing Winamp with Erbium or Insomnis open and then restarting Winamp, then see if the colorthemes show where pieter just said they should be. If they do show there, then it's the same problem I had and is most likely caused by a 3rd party plugin.

Similar threads

Rate this thread

Sponsored Links: